Page Not Found Error

Topics: Setup
Apr 18, 2007 at 5:04 PM
I just installed the LitwareHR application and get the 404 Page not found error. I followed the readme and I can browse to the Contoso and Fabrikam pages so I've set up my host file properly. Any ideas what I've missed?
Apr 18, 2007 at 9:38 PM
  1. Did you try to browse www.litware.com site from within the IIS console?
    1. What happens when you do that?
  2. Did you double-check the host file? It should have the "127.0.0.1 www.litware.com" entry.

Please tell me if that helped you.
Thanks!
Ariel Schapiro
Apr 18, 2007 at 9:52 PM
1. Yes, I did browse via IIS and same 404 Error.

2. I did double check the host file and my host file is as follows:
127.0.0.1 www.litwarehr.com
127.0.0.1 www.litware.com
127.0.0.1 services.litwarehr.com
127.0.0.1 www.contoso.com
127.0.0.1 www.fabrikam.com
Apr 18, 2007 at 10:45 PM
Does the www.litware.com website point to the folder where the litware website is installed? C:\Program Files\Microsoft AST\LitwareHR\Src\Litware\Litware.WebSite for example.

Maybe the issue is around there...
Please tell me if that helped you.
Thanks!
Ariel Schapiro
Apr 18, 2007 at 10:55 PM
Are you installing LitwareHR on Windows 2003 or Windows XP?
Did you download the appropiate installer?

Thanks!
Ariel Schapiro
Apr 20, 2007 at 5:20 PM
Hi Ariel, thanks for helping.

I verified that www.litware.com is pointing to the correction location. It is indeed set to C:\Program Files\Microsoft AST\LitwareHR\Src\Litware\Litware.WebSite and I do see all files and directories as well inside the IIS console.

I am using Win2003 server and installed the non-XP install.

It seems that I am missing something so simple, at least I hope that is what it is. Any other ideas?
Apr 20, 2007 at 6:00 PM
  1. In IIS's www.litware.com website:
    1. Do you have default.aspx in 's documents list?
    2. ASP.NET version is set to 2.0.50727?
  2. If you try browsing http://www.litware.com/default.aspx you get the same error?
  3. If you try browsing http://www.litware.com/Imx/header.png you get the same error?
  4. Did you try iisreset?

Thanks!
Ariel Schapiro
Apr 20, 2007 at 7:55 PM
Ok, here goes:

1.1 - Default.aspx is in documents list
1.2 - ASP.Net version is correct

2. Same error browsing to http://www.litware.com/default.aspx

3. I see the header.png when browsing to http://www.litware.com/Imx/header.png. No problem there.

4. Yes, iireset attempted, same error.
Apr 21, 2007 at 12:47 AM
Does the ASP.NET v2.0.50727 web service extension is in the Allowed state?
You can check that on IIS's Web Service Extensions.
Additional information: http://support.microsoft.com/default.aspx?scid=kb;EN-US;315122

Hope that helps :)

Thanks!
Ariel Schapiro
Apr 23, 2007 at 4:24 PM
YES! I knew it had to be something so simple. My setting were not set to Allowed so I switched it on and I can now navigate to the site.

Thanks so much for the help! I look forward to digging into the application.

Thanks again!